Entegrity Solutions - Secure Access Management and Content Delivery Solutions
ACCESS-DENIED PERMISSION ERRORS
(306GR 13-Jan-1998)

PROBLEM: A user who should have appropriate privileges to a document, script, or DLL protected by the Security Adapter is being denied access.

CAUSES:

These messages may be displayed as a result of any of the following causes:

1. The DN of the user (Entrust certificate or SSL Client certificate) is not set EXACTLY as the Web server is reading it.

2. The NetCrusader Security Server license is not installed -- only the DCE Security Server license is installed.

3. The Security Adapter does not have permission to map the DN of the user.

SOLUTIONS:

For Cause 1 (above) you can:

  • Check the NT Event Log (Application log) to view the DN for the user (it will be in a stop-sign error box).
  • Make sure that the DN matches EXACTLY (it appears between the << and >> marks but doesn't include them) by putting it into a user in Commander (X.500 DN tab for User Properties).

For Cause 2 (above) you can install an appropriate NetCrusader Security Server license.

For Cause 3 (above) you can:

  • Verify the user called "wcsecad/<machine>" (where <machine> is the short DNS hostname of the Web server) is a member of the "wc-delegates" Group.
  • Find the user with the proper X.500 DN and be sure the Delegation Group (set in X.500 DN page of User Properties) is set to "wc-delegates".


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